Inicio > How to, Informática > Paquetes rotos en Linux Mint Debian Edition (LMDE)

Paquetes rotos en Linux Mint Debian Edition (LMDE)

Tras el fracaso con Linux Mint 12 decidí instalar LMDE en mi ordenador de sobremesa. La sorpresa vino al encontrarme que había paquetes rotos tras la actualización de LMDE y no había manera de arreglarlo a pesar de seguir los pasos que ya indiqué en otra entrada

La solución fue cambiar las sources.list más que nada porque LMDE ha pasado de testing a stable y el DVD de instalación que yo tengo no tiene reflejado ese cambio.

¿Cómo hacerlo? Editamos con permisos de superusuario nuestra sources.list ejecutando sudo gedit /etc/apt/sources.list desde un terminal y en el documento abierto sustituimos testing por stable allá donde nos lo encontremos, de tal manera que quede así:

(*) Lo he modificado en las tres últimas líneas, una vez por línea, si os fijáis los “stables” están muy juntitos… 😉 😉 😉

Después de modificar el sources.list debes actualizar el sistema: sudo apt-get update && sudo apt-get upgrade

¡¡Y se acabó el problema!!

Fuente: Tombe85.

Anuncios
  1. David
    19 enero 2012 en 14:23

    Bueno pues reinstalare el sistema y seguire la guia esta (la guardare en el hd externo) a ver si así deja de salir paquetes rotos cada vez que instalo algunas aplicaciones como openshot y demás, por que ya toca limpieza al sistema, y se que aplicaciones quiero y cuales no.
    Saludos y grácias de todas formas x)

    • 19 enero 2012 en 16:13

      No deberías de tener problemas de paquetes rotos en LMDE que no se pudieran solucionar sin reinstalar… Aunque si quieres hacer una limpieza te puede venir bastante bien, es más rápido que andar quitando paquetes 😉 😉 😉

  2. Norberto Perkins
    1 febrero 2012 en 8:25

    He seguido sus indicaciones y ha resultado tal cual como Usted lo explica en el pots. Solo tengo algunas dudas…. El ícono de actualizaciones no sale mas y solo aparece cuando lo pulso desde Sistema ….Administracion y Gestor de Actualizaciones, el cual perdura hasta el cierre del sistema. Al iniciar nuevamente no se hace visible. Esto es normal ????Afecta en algo ??? Tengo programada las actualizaciones para que se realicen por día previa confirmación , como venía por defecto . Ahora bien , al momento de actualizarse , al ser stable , se incorporarán actualizaciones ya probadas no o de las denominadas testing??? Disculpe mi ignorancia al respecto y desde ya gracias por hacerle perder su valioso tiempo . Abrazo .

    • 1 febrero 2012 en 17:16

      El que no aparezca el icono de actualizaciones de todos modos no es ningún problema, y, además, en mi caso siempre está marcado como actualizado y no avisa de las actualizaciones hasta que yo no actualizo el sistema.

      Con respecto a la segunda pregunta en teoría son aplicaciones estables, ya que por eso es la versión estable de Debian. Aunque puede ser que se añadan paquetes de Mint que no hayan sido “tan testados”. Es decir, que en su gran mayoría estamos hablando de un sistema operativo bastante estable, y, de hecho, todavía no me ha dado ningún tipo de problema en el equipo donde lo estoy probando.

      • Norberto
        1 febrero 2012 en 17:20

        Muy amable Señor por su pronta respuesta. Pensaba que era así , pero , quería tener la palabra de una persona idonea en el tema. A su entera disposición y mi agradecimiento y congratulaciones por su link que es de mucha ayuda. Norberto

      • 1 febrero 2012 en 17:23

        Gracias a ti por visitar el blog!!

  3. Hugo
    8 septiembre 2012 en 0:01

    Fue de muchisima ayuda esto, mil gracias……perdon pero a la fecha habra otra nueva solucion?

    • 8 septiembre 2012 en 13:34

      Pues supongo que sí, puesto que LMDE utiliza la última versión de Debian…

      Ahora mismo no te sé decir porque quité LMDE del ordenador porque veía el proyecto un poco dejado y, además, me decepcionó que LMDE no fuera una verdadera Rolling Release…

  4. 13 enero 2014 en 16:21

    hola muy bueno tu post pero ha mi me sigue diciendo esto
    Leyendo lista de paquetes… Hecho
    W: GPG error: http://ftp.debian.org stable Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 6FB2A1C265FFB764
    y lleva un tiempo asi
    gracias por contestar

  1. No trackbacks yet.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: